Recover Word Deleted File

ai-tee

Beberapa bulan ini sibuk dengan mengisi Borang Akreditasi Program Studi dari BAN-PT.
Malam ini lembur mengisi bagian-bagian yang masih belum sempurna.
Saat mau pulang dan simpan file versi terakhir, ternyata saya malam menimpa versi terbaru dengan versi 6 jam sebelumnya.
Wah wah wah, kerjaan 6 jam jadi terbuang sia-sia…

Akhirnya inget program GetDataBack for NTFS, dicoba deh untuk recovery dan perlu 2 jam.
Sambil menunggu, cari-cari tutorial dan ternyata ada cara yang jauh lebih singkat dengan mencari file backup dari MS Word di folder

C:\Users\*YOURUSER*\AppData\Roaming\Microsoft\Word

Ada banyak file *.wbk yang merupakan file hasil autorecovery dari MS Word.
Langsung saya sort by “Date modified” dan buka yang terbaru, YES… ketemu deh file yang tadi tertimpa.
Setelah save-as file .wbk tersebut jadi .docx kembali, saya bisa pulang dengan tenang.
Ah, ternyata autorecovery yang kadang menjengkelkan karena sering menginterupsi pekerjaan, sesekali memang sangat berguna πŸ˜€

Sumber: http://superuser.com/questions/107143/how-to-open-recovered-files-in-word

No Comments

Unroot Android 2.3.4 on Xperia Ray

ai-tee

Setelah beberapa bulan menggunakan Android, gatel juga mau ngurut (baca: nge-root / unrooting).

Karena dapat referensi dari Mrs.SaronKaye jadi akhirnya pakai Easy Rooting Toolkit (zergRush Exploit) dari xda-developers.

Ternyata prosesnya memang Easy.

Android 2.3.4 Build 4.0.2.A.0.42 di Xperia Ray saya sudah berhasil diurut πŸ™‚

Selamat ngurut kawan.

Sumber: http://forum.xda-developers.com/showthread.php?t=1320350
Link terkait: http://www.kaskus.us/showthread.php?s=b9f0a40faba3153bf43bab92814cd75e&t=10874153

No Comments

Drop port scanners on MikroTik Router

mikrotik

Karena sempet kecolongan open proxy di port 443, tadi coba iseng-iseng cek aktivitas drop packet pada chain input di MikroTik router. Ternyata eh ternyata, ada yang hobby banget port scanning ke network kantor.
Maaf bung, proxy sudah diamankan! Port 443 tidak bisa digunakan lagi πŸ˜€

Tapi karena gatel liat log yang terus-terusan bertambah, akhirnya nambahin juga deh dynamic port scanning rule di filter.

Berikut rulenya:

/ip firewall filter
add chain=input protocol=tcp psd=21,3s,3,1 action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”Port scanners to list ” disabled=no
add chain=input protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”NMAP FIN Stealth scan”
add chain=input protocol=tcp tcp-flags=fin,syn action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”SYN/FIN scan”
add chain=input protocol=tcp tcp-flags=syn,rst action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”SYN/RST scan”
add chain=input protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”FIN/PSH/URG scan”
add chain=input protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”ALL/ALL scan”
add chain=input protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”NMAP NULL scan”
add chain=input src-address-list=”port scanners” action=drop comment=”dropping port scanners” disabled=no

Begitu juga di chain forward, dapat dilakukan hal serupa. (ganti “chain=input” menjadi “chain=forward”)

Sumber: http://wiki.mikrotik.com/wiki/Drop_port_scanners

No Comments

Salah alamat

obrolan ringan

Resiko punya email yang common, sering banget masuk surat nyasar. Paling banyak adalah email corporate yang kirim penawaran, mulai dari peralatan IT seperti Cisco, ataupun surat internal yang berisi draft project dan kadang-kadang keuangan.

Kalau sudah begitu, saya harus reply ke sender bahwa “I’m not the right timotius that you want to contact” alias salah alamat.

gmail.

No Comments

cPanel Log Location

server

Anda mengelola web server dengan cPanel/WHM sebagai control panelnya?

Jika ya, pasti ada kalanya Anda perlu melihat log dari web server Anda.

Berikut beberapa lokasi log penting:
/usr/local/cpanel/logs/
/usr/local/apache/logs/
/usr/local/apache/domlogs/
/var/log/messages

Atau Anda perlu poster loglocation dari cPanel, silakan unduh di http://www.cpanel.net/images/loglocationsposter.jpg

Sumber: http://forum.hostican.com/virtual-private-servers-VPS-f9/cpanel-and-whm-log-file-locations-t336/

loglocationsposter

loglocationsposter

No Comments

Securing PHP

linux

Belajar dan terus belajar. Salah satu enaknya mengajar di bidang IT, harus terus belajar. Ilmu yang kemarin dipelajari tidak selalu cukup untuk menangani masalah keesokan harinya.

Hari ini belajar hal baru lagi, bagaimana mengamankan konfigurasi PHP di web server.

Beberapa konfigurasi pengamanan yang umum bisa dilakukan dengan mengatur file php.ini, di antaranya untuk opsi safe_mode = On dan registers_globals = Off.

Sumber: Securing PHP: Step-by-Step | Symantec

No Comments

Zimbra create multiple account

server

Karena ada beberapa puluh email baru yang perlu dimasukkan ke server mail zimbra, saya memilih untuk melakukan proses pembuatan account menggunakan zmprov.

Berikut langkah-langkat pembuatan multiple account.

1. Buat file text bernama email.zmp dengan isi sebagai berikut (pastikan user zimbra punya hak untuk membaca file email.zmp)

createAccount user1@domain.org user1password displayName ‘user1 display name’ sn user1lastname
createAccount user2@domain.org user2password displayName ‘user2 display name’ sn user2lastname
createAccount user3@domain.org user3password displayName ‘user3 display name’ sn user3lastname

(Catatan: Bisa ditambahkan zimbraPasswordMustChange TRUE di belakang setiap baris jika diperlukan)

2. Import file text dengan perintah zmprov (dengan user zimbra)

$ zmprov < email.zmp

Sumber: http://wiki.zimbra.com/wiki/Bulk_Provisioning

No Comments

Static Route di CentOS

linux

Tiba-tiba saja ada keperluan untuk menambahkan static routing di CentOS, karena belum hapal lokasi file konfigurasi-nya, akhirnya minta bantuan Mr.Google.

Dapat juga link yang sangat membantu dari centos.org.

1. Buat dan edit file route-interface (dalam kasus saya, interface=eth0)

# vi /etc/sysconfig/network-scripts/route-eth0

2. Tambahkan informasi static route yang diperlukan pada file route-interface tersebut (format X.X.X.X/X via X.X.X.X dev interface)

10.0.0.0/24 via 192.168.1.50 dev eth0
192.168.0.0/16 via 192.168.7.50 dev eth0

3. Restart service network

# /etc/init.d/network restart

4. Cek routing table, apakah static routing yang ditambahkan sudah termuat

# /sbin/route -n

Sumber: http://www.centos.org/docs/5/html/5.1/Deployment_Guide/s1-networkscripts-static-routes.html

No Comments

Fixing Zimbra Server

server

Saya baru saja membetulkan mail server zimbraΒ  milik kantor. Ternyata sudah mati selama 1 minggu, wah ternyata kurang aware dengan down-time, bukan hal yang baik sebagai admin πŸ™

Sumber masalah karena ClamAV tidak bisa hidup karena aturan baru yang dimulai semenjak 15 April 2010.

For those using ZCS 5.0.16 and prior, come 15 April 2010 anti-virus definitions will no longer update AND your ClamAV instance will stop working entirely.

EOL Source: http://www.clamav.net/2009/10/05/eol-clamav-094 “Starting from 15 April 2010 our CVD will contain a special signature which disables all clamd installations older than 0.95 – that is to say older than 1 year. We plan to start releasing signatures which exceed the 980 bytes limit on May 2010.”

Announcement ini mestinya sudah lama diposting, tapi saya yang kurang aware. Jadi harus ada down-time yang seharusnya tidak perlu terjadi.

Proses troubleshooting dilakukan dengan update ClamAV ke versi 0.95. Berikut langkah troubleshooting untuk Debian-4.

cd /opt/zimbra
wget -bc http://files2.zimbra.com/downloads/6.0.6_GA/zcs-6.0.6_GA_2324.DEBIAN4.0.20100406160442.tgz
tar xf clamav-0.95.1.tar
zmcontrol stop
rm clamav
ln -s clamav-0.95.1 clamav
ls -l clamav
zmcontrol start

Sumber :

http://wiki.zimbra.com/wiki/ClamAV_-_Updating_clamd_for_releases_earlier_than_ZCS_5.0.16

No Comments

Akhirnya CCNA

ai-tee

Akhirnya lulus sertifikasi CCNA, setelah 4 tahun tidak kunjung ujian πŸ˜€ hahaha…

Senin yang lalu ambil CCNA 640-802, dapat score 974, hasil feedback nilai kurang baik di bagianWAN.

Tinggal menunggu sertifikat dan ID dikirim dari Cisco, sekitar 2-4 minggu dari test.

Oya, bagi yang mau mengambil sertifikasi CCNA, ada situs yang bisa membantu :

– http://www.9tut.com/

Ini situs yang sangat membantu saya mempersiapkan soal lab, semua soal lab yang saya temui di “real exam” sudah dibahas semua di situs ini. Jadi saat mengerjakan soal Lab, tinggal senyam senyum saja πŸ™‚

– http://certexam.blogspot.com/

Sempat juga download beberapa soal ActualTest, Pass4Sure, TestInside dan VCE dari situs ini. Tapi tidak sempat dibaca sama sekali, berhubung waktunya super mefet πŸ˜€

No Comments
« Older Posts
Newer Posts »